Build 2 Experiences


#1

Figured I’d give Build 2 a shot since bouncing off the first build. My notes:

In the options menu, clicking “Reset All Options” immediately closes the menu. Since at the bottom of the options menu it clearly says “Adjustments will not take effect until ‘OK’ is pressed” I was left someone confused as to whether Reset All Options had actually done anything.

I clicked New Game (I think!) and, after the initial very long load screen, was thrown directly to the lava cavern part of the beginning. Already had a bunch of stuff in my inventory. Wandered up the path to Marcaul. The gate was closed, and all the portals were inactive. Oh well, guess I’ll try…

New Game again. Got the proper intro this time, with the picking how beefy my arms are and all that.

On the load screen this time:
{[Input:Interact]}: Next Tip

Okay now I’m at the level start that I recognize from before.

Typhon’s first voiceover really should be saved until much later. The player gets zero chance to wonder who this guy is before BAM he’s shouting right in your ear. Pacing, guys. A little dramatic buildup please? Imagine if the first level of Thief had the Trickster impotently taunting you.

Walked up to a skeleton and bonked him with a femur. Got a feat popup but with no name.

The tiny screenshots that appear when feats are earned are bizarre. Some sort of “feat unlocked” symbol with the name of the feat next to it would look a lot better.

The whole “The • symbol is visible.” thing is still unintuitive as hell. No, game, there is no symbol visible. The text should just be honest that it’s giving the player information he can’t see. Like, “This door requires the orb key.” or something like that.

There really should be some sort of text notification when you use a key to open a door, since keys are used automatically.

I still hate “Mineral Ore” as loot. You know what mineral ore is just a fancy way of saying? Rocks. I’m picking up rocks. I feel like the game is pranking me into collecting rocks, because that’s what RPG players do, right? Pick up literally everything they can. If these things are actually valuable, they should have a more valuable-sounding name, like “Silver Ore”. And I wish they didn’t fly into my mouth when I pick them up.

The first silver sapling you encounter has “Activate” as its tootlip. What the heck does activating a tree mean? I guess that means I got a seed from it? The tooltip doesn’t go away after it’s been frobbed either.

The way held objects shoot WAY UP INTO THE SKY when you’re aiming a throw is still super weird.

Player arrows still fly so freaking fast they seem like they’re hitscan instead of physical objects.

Still weird that water bottles can’t be placed in inventory… and that they glow bright blue… and that they’re laying around freaking everywhere.

The standing torches weigh… 240 POUNDS?! Seriously, just ditch the weight display. It’s not useful information. We can already tell well enough how heavy things are by how slowly they drag around.

Walked into a standing torch and the I somehow climb on top of it?

Picked up a Memora and a screen popped up! Where’s the close button? There isn’t one? Come on.

Finally got back to Marcaul. Ah, I was supposed to climb the nearby platforms to get into the city. If only the lizard right inside the gate had SAID THAT instead of just floating there watching me like an unhelpful bastard.


#2

No. It is a good update. But still feels very beta-ish. Clearly the game was released months ahead of when it should have been, probably to satisfy some sort of deadline 505 imposed.

My chief complaint is still the same. Lack of RPG elements (chiefly dialogue). I have gotten over the fact that this was never going to resemble UU in any way, despite the KS promises.


#3

I haven’t played this build (yet) but I’ve voiced this concern before: the more the game is cleaned up, the more the NPC dialog omission will stand out.

But…some posts suggest that the NPC thing is being addressed, if only slightly. The game has always cried out for dialog, and realised factions. I don’t think anyone would object too a basic text system of branching tree dialogs, even if limited and repetitive.
Plus, people have got used to the beta test element, and perhaps would be more forgiving. They can always be refined later, once the structure is in. I wonder…can any Unity bods chime in?


#4

This game is not magically going to become the purist UU sequel many were hoping for, but the added polish still makes a huge difference.

The initial release was really almost a late alpha stage. It wasn’t release worthy. This one feels like what it should have been at launch at least. There are still bugs, but the fundamentals and major features are all in and working at least.

Personally I don’t have an issue with the kind of Underworld-meets-Dark-Messiah vision they have for the game, I took the game for what it was. But the level of polish made it almost unplayable. I’m looking forward to giving Update 2 a go.


#5

Thanks for the feedback guys, much appreciated. The goal is for this to be another hopefully large step forward for the game.

Regarding the game overall, Frogacuda, I think of it like “System Shock + Thief in a fantasy dungeon”. The gameplay is more like those games than the original underworlds


#6

Oh god, you’ve said it now Walter :blush:

…yep, you’re going to chop some flack for that, even though it’s essentially true and a variation of what Sam said way back in another forum.


#7

Haha! It’s actually not the first time I’ve said it, including in these forums :slight_smile: Frankly, it was a revelation to me I think around September last year–like, oh, I get it now, this is what the game is like. Wish I had figured that out sooner . . .


#8

I mean, for all the talk about not delivering “what was promised in the Kickstarter,” the Kickstarter was super clear that you guys were doing something new. So I’m not sure where that specific complaint comes from.

No one has to to like any specific design decision, of course. But it’s just flat-out wrong to say we were lied to in the pitch.

Anyway, I’m looking forward to checking out the update this weekend.


#9

Hope you enjoy it! It’s definitely a lot better now IMO.


#10

The problem with having a KS too early is that the game becomes anything and everything in the viewer’s imagination. Double Fine ran into this trouble with Broken Age, because it didn’t matter if the game at the end was good, it just couldn’t be this platonic ideal of an Adventure Game that existed in the minds of backers. UA’s KS was likewise tantamount to scribbles. Super early engine test stuff that told us very little.

Because of that, I personally didn’t back the game until after the art overhaul and after it became clearer what it was. At that point I had no false idea of the game, and so I wasn’t bothered by this when it came out.


#11

After working with a couple of Kickstarter games now (Amplitude and UA, but remember I came in long after UA was kickstarted), I question whether Kickstarter is a good platform for video games. Because most games are iterative and often deviate off the original vision, it’s easier for them to veer off into something original backers didn’t think they had signed up for.

For pure remasters, remakes (like Amplitude) or very formulaic games, Kickstarter could work. Board games work even better, IMO, since you can design most of the game up front, leave like 5-10% for fan feedback, then use Kickstarter money to fund physical manufacturing.

Just my thoughts

edit - misspelled “remasters”


#12

This thread is supposed to be about Build 2, but your revisionist apologism compels me to remind you that literally the first words of the Kickstarter video were “The RPG masterpiece lost for a generation returns”. Not “The RPG masterpiece lost for a generation gets reimagined as something completely different.” No matter how much they talked about innovating and trying new things, the reasonable assumption was always that these new things would be within the same general framework as UU. Otherwise what would be the point of selling UA as a successor to UU?

For you to claim you don’t know where the complaints come from is, most charitably, disingenuous.


#13

I think it’s tough for a lot of people to wrap their brains around what “development” means. I see this a lot with movie discussions as well, where people think that writers and directors start on these big movies with a fully formed plan of what everything is, rather than grinding through dozens of drafts, meetings, conversations, iterations, etc. until their very general starting idea finally takes shape into something (which is often totally different).

I’d imagine it’s even crazier for games, where you have a whole bunch of other technology and gameplay systems to worry about on top of it.


#14

Boo hoo.


#15

…a small boo hoo to your big boo hoo, GameOutLoudRob

…I was typing when a previous comment was posted, right down to ‘revisonist’ :wink:

I think the truth has to be be somewhere inbetween, especially for a game as famous as UU, and with 20+ years under it’s belt. But let’s not use this a justification for everything. It doesn’t have to be re-make-or- something-completelydifferent. The lack of ‘connection and feel’ compared to the originals is still a problem for many, but then you can dine out forever on semantics …‘what does feel mean, exactly?’ …but people know it, when they feel it.

The changes made and being made really help, and go a long way to winning back fans, but a lot of people are going to be put off if they see it as justification for the game design brief at launch, which is very different to even 6 months or one year prior. And further back long before Sam and Walter’s time.

I think the KS point stands, but it’s not an answer for all issues. ‘Iterative’ and ‘deviate’ can be for many reasons, both internal and external. Keeping track of those for this game would produce a book. It’s tempting to line-up everything up with 20-20 hindsight, but that wasn’t how it happened.

Still, as Walter says, he’s speaking in a personal capacity (but just wait for the ripples on other forums).

Walter, you are honourably renamed ‘speaker of hostages’ to fortune ’ for the day :slight_smile:


#16

I think it’s great for games that are far enough into development that they can show backers with some confidence what they’re buying into. Games like Overload, or Toejam and Earl, or Freedom Planet don’t get blowback because they don’t leave as much to the animation. You see the thing you’re backing, maybe even get a demo, and you know what it’s going to be.

But going to KS with a dream and some concept art is a recipe for blowback. If you leave things up to people’s imagination and then let them them give as much money as they want, people are inevitably going to be disappointed that they got their hopes too high and paid too much.


#17

I’ve had a quick dabble with Update 2 this evening and can say that it is certainly an improvement on what we had at release (I skipped update 1 so cannot comment on that!)

As others have mentioned it is not going to bridge the gap to the “true” Ultima Underworld style experience that many (rightly or wrongly!) wanted to see from UA, but it is undoubtedly a better game than it was before. I’m still sad that the game I had hoped for will probably never see the light of day, but that’s life sometimes!

It’s certainly far better optimised that at release, it runs pretty consistently well from what I have played so far and that makes a big difference to how everything feels in a highly “tactile” game such as this.

I certainly plan to keep digging around in this latest version and I fully expect to be enjoying my time.


#18

… and then it went and crashed on me!

Messing around setting fire to things in Upper Erebus and it dumped me out to the desktop!


#19

Yeah, I’ve had at leas three crashes. But hey, at least the save system works, so I only lost 5 minutes of progress and not 45!

I moved the game to my SSD and the load times are down to a tolerable 20-45 seconds.


#20

Some notes from my first Update 2 run:

STARTING

I feel like there should be some reward for climbing the chains after exiting the initial starting area. In fact, I’d love to see more small rewards – more of a “yep, we thought you might look here” than anything – squirreled away in odd places that players might explore to.

I’m still having to double-click and then drag on an object in my inventory to consume it. Is this just me, or does everybody else have to do this to consume something when you’re looking at it in your inventory, and everybody’s OK with this?

Swinging a bone (and maybe any melee weapon but I haven’t tried a different one yet) to hit a door causes a long movement forward, and has a long delay before being able to move backward.

In the “crouch to tread lightly” area, why can’t I take any of the arrows stuck in the floor? This is sort of a rhetorical question; obviously I understand those arrows are just scenery… but players can get a little grumpy when you dangle useful objects in front of them that can’t actually be used.

Subtitles are on by default. Is everybody OK with that?

My word, this character I’m playing is a delicate flower – hitting the ground from nearly any height is a death sentence. Exploring hard-to-reach places is causing me many more “deceleration trauma” deaths than previously. I understand that falling from great heights ought to do damage, but taking so much damage from relatively small heights is a little frustrating.

Something is off with the skill UI: some skills I can afford are grayed out, and some I can’t afford are shown with the “available” image. For example, I bought the basic Stealth ability, and have 2 points left, but Night Vision (2 points) and Athletic Ascent (1 point) are still grayed out and presumably unavailable for purchase. OTOH, Escapist, Concealment, Unseen Dash, and Backstab (all costing 3 points) are lit up as though I can purchase them. Similarly in the Magic tree, after purchasing the basic skill True Names (2 points) is grayed out, but Mana Reserve, Battle Magic, Temporal Dilation and Enchanter are all still lit up as if they’re available.

I cam still reach through the bars to open the chest in the room just after Resherak and grab its contents.

MARCAUL

Very minor gripelet: at Aelita’s the first time, the Deep Elves offer one pair of Deep Elven Boots (5% armor +12% speed), and one pair of Deep Elven Boots (5% armor +12% speed) but which require a faction unlock. Why would I ever wait to buy the ones that require a faction unlock?

Bottom of the Grand Staircase in Marcaul: “Journey to Haprukala’s camp in {level} to continue your quest.” (This same text appears in the Quest page.)

UPPER EREBUS

Low on health, fell into the spike pit in the Rotating Blades of Death corner of the Ruins of Gwern, game crashed.

Overall, movement does feel smoother, and the combination of 1) replacing the Ring of Portals with the Grand Staircase and 2) personalized quest delivery delivers a tangible improvement in the feel of the game world as a unified place.

More later when I’ve been able to explore more of the dungeons, but Update 2 feels to me like a real improvement.