Build 2: Side quests that use chests not working or different?


#1

First, I love the work you’ve all put into this update.

I completed the game back in December and despite the problems I still enjoyed it. And the recent changes make it feel like a fresh experience. I especially like the central “grand staircase” linking the levels together - feels like a cohesive dungeon now.

Everything was going well until I tried a side quest to recover “ripper hide armor”. In the previous build(s) these types of items were in chests and I assumed the same with Update 2. However the persistence state is so good on the levels that none of the chests reset and in this case there is only one chest in a the tiny highlighted section of Upper Erebus (blue highlight on map to indicate quest location).

It’s basically just one room with a stone walkway across some shallow water that sometimes has an enemy on a platform to the left and there’s just a single chest with a lamp on the bridge. That’s pretty much the makeup of this highlighted area.

I looked in the water, checked the walls, etc. to see if you implemented some new hiding spot for quest items like this armor. I even busted the few vases in the area.

I want to keep playing but I fear that this type of quest that involves chests may be busted.


#2

Pretty cool that you got the issue in such a small zone: it essentially eliminates user error as a possibility.

Might be worth sending them a savegame of that situation?

Can also try LOADING a savegame of that situation, or moving to another level and back, so that it respawns the level?

Worst comes to worst, can also abandon the quest (which is through the main menu, not the quest screen).


#3

Thanks Dewi.

I don’t think leaving and returning the level makes a difference (and I think I tried it) because the chests stay open.

I may just abandon and go for another quest, however ANY quest that uses a chest may have this problem.

I find it a little hard to believe that the ability to keep chests persistent wasn’t reconciled with the need to have then close back up in order to hold a future quest item - or something like that. Or have these types of quest items out in the open or even in a vase or box.


#4

Interesting. Chests in my game still seem to “refresh” every time I return to an area - the abyss seems to be a connected space but still not a persistent one in my game at least…


#5

Same. Certainly, when I return from Marcaul, levels are rebuilt and refreshed, ready to destroy again.


#6

I did get that particular chest to reset by restarting the game and using “continue” but the rest of the chests in the area did not reset.

Of course, this is a problem over all because there’s no requirement to go Marcaul between quests in a given level. If leaving the level and returing solves the problem then it’s a workaround but not a good in-game mechanic.


#7

The problem appears to be caching in answer to why does it not always happen when re-loading.

If the player moves just between Upper Erebus and Marcaul (after starting the game so that no other level data is in memory) the level data appears to be pulled from memory which is why I don’t think the chests re-spawn. I think this is what I was experiencing.

Forcing a load from disk by going to a third area and back again seems to load from disk and re-spawn.