First impressions - U2


#1

I loaded UA for the first time today, with the U2 patch active. Overall it’s a promising game, with more technical issues in the first 15 minutes of play than I had hoped for.

Here are those issues in detail.

  • QoL - no graphics detection when starting the game. I can go in and set quality and resolution, but it’s a manual step I have to take
  • QoL - the resolutions are not in the order I’d expect. There’s quite some hunting going on to find the one that matches my monitor. They feel “jumbled”
  • Bug - setting resolution after starting the gameplay proper is not retained when quitting and launching again. Setting resolution before entering the game - on the main screen - is also not fully retained. When I set 3440x1440 @59Hz and come back in and check resolution, it shows 2560x1080 @ 60Hz.
  • QoL - 3440x1440 @ 59Hz is a thing, 3440x1440 @ 60Hz isn’t an option. That’s a bit - unintuitive
  • Bug - the very first hint shown had {Interact} or something like that, not “E” for Next Tip - solved after quitting and restarting
  • Bug - after discovering the Fist spell, casting it for the first time had audio “glitch” - stuttering, channels cutting out - for about five seconds, after which it recovered
  • Bug - mouseover on inventory items has overlapping descriptions; skill tree is missing the bottom. That’s at native resolution of 3440x1440, 59Hz. I’ll attempt to insert screenshots below.
  • Immersion Breaker - in the mana room early on, I can be attacked and attack through the locked steel door
  • Immersion Breaker - 44lbs crates don’t behave like 44lbs crates, they bounce and are easily knocked off their position. Does the physics engine support weight in any meaningful way?
  • Frustration - “find the abyssal keys”, but nothing I can see anywhere in the mana/first spellrune room. It’s possible I’m just dense, but it’s also possible that key is a little too well hidden.

That’s it so far. I like the experimental nature of the game, trying environment interactions and experimenting with spell runes. The bugs detract from a great experience.

Screenshots of the graphical issues:
https://imgur.com/a/zBSUvAN


#2

Thanks yorick, we’ve logged those and have a fix in for some of them (e.g., the placeholder text stuff)
We’re working on repro’ing this one: - Bug - setting resolution after starting the gameplay proper is not retained when quitting and launching again. Setting resolution before entering the game - on the main screen - is also not fully retained. When I set 3440x1440 @59Hz and come back in and check resolution, it shows 2560x1080 @ 60Hz.
I’m not seeing that behavior at 1080 or 1440p, anyone else? Wonder if it’s isolated to wide-screen or higher resolutions. Let me know


#3

My guess is it’s related to ultra-wide.

I happened across a physics issue with a skeleton “jigging” in a grate once killed. Video of that is here: https://www.dropbox.com/s/erneat2qcj63ap5/Desktop%202019.02.24%20-%2020.32.29.02.mp4?dl=0