I finished the game on ps4


#1

I slept on it after beating it so I wouldn’t rant but c’mon, how can you not?

Nothing works.
I would wager 98% of all enemies would completely ignore you if you just run past them, and most you could run past with a light source out. If you walk past and give them time to react they still don’t react. Does full plate make more noise? Who knows? A couple of times the entire game I made some noise which made me think the enemies reacted to it. But thousands of times I made noise and they didn’t react. The second last main mission was some big deal, I escaped the crucible. Well all I did was whack a wooden “set piece” with the mace of light I used virtually all game and nobody reacted even though there were bad guys a couple of feet from me, and I walked out of the last mission. In a stealth game running around with a mace that is a glow stick seems a little counter intuitive but believe me it isn’t.

I was constantly confused
Did I make a mistake with the rune combo for teleport? Or is the game just not working? Who knows?
Nothing works, you don’t actually know if you are doing anything correctly. You may have just pulled off a perfectly ghosted mission but maybe the enemies cannot see you at all. Who knows? Well I have an idea, I will run up to the enemy, jump up and down in front of them, throw boxes at their feet, light the boxes on fire with the only important spell the game fireball (the world’s goofiest fireball spell) and the enemy will not only not see me but it will stand there and burn to death without reacting. Every creature will stand there and burn to death without reacting.

Some skeletons and lizards have AI that at least looks like it’s working until you back away about 2 feet. Then if they are a lizard they will most likely pull out a bow that does not do damage, or run out of the area. At first i thought “maybe I do enough damage and it runs away” but no, the monster would glitch out 98% of the time.

All game.

Not just once, ALL GAME.

The most fun I had was breaking the game by lighting things on fire and just watching the most inefficient coding in the world crash the ps4. You give us big fire set pieces and if you light them the game can’t handle it and crashes. I remember seeing the bridge in the final level in the back starter pitches. Well after years of waiting I see the same basic bridge. Exciting huh? No, setting it on fire and having an instant reload when you die means you are trapped in a slide show of about 3 frames per second and even if you die you are returning to the slide show. I don’t think I am explaining this one too well but the problems that happen are almost indescribable.

Specifics

Bellums have no AI at all and some have no arms
I encountered invisible Bellums on multiple occasions in multiple locations, I could see the outline, but then I reloaded and discovered they weren’t invisible and just glitched. But invisible enemies that have no AI standing around in a dungeon gave me a laugh. You have to think outside the box and make your own fun with this game, just like the trailer implies.
The create plant “rope arrow spell” creates a short stump of grey wet spaghetti that’s about an inch long. Jump up though and magically extends to about 5 times the length.
The chains, oh man those chains, the physics are like your drunk and on the moon
The clearer of obstacles hammer doesn’t clear any obstacles and yes I read what type it was supposed to work on.
Sniper arrows and quite a few other items have no icon.
Multiple weapons have jargon like unity.object as item descriptions.
Some side quest seemed to break the main game until I ran around for ages trying to figure out what I had to do but to get the main story to reappear in the quest log
Fire balls never disappear, maybe that was the intention but I have no idea why. I would just chuck a few around, then back track and see them still burning half an hour later.
Water doesn’t put out tiny fires, it puts out torches and giant cauldron braiser thingos.
I was walking on the ground multiple times and all of a sudden I was falling head first into the ground over and over again and dying.
An entire environment disappeared, multiple times.
The way you collect mana doesn’t work often. You are meant to walk/jump into floating blue stuff and it works maybe 30% of the time.
At least 50% of the feats I tried didn’t work. I couldn’t level up skills. Getting only 1 skill point when your feats already don’t register is bad. I finished the game with about 6 skills out of about 50. I tried really hard to level up skills.
You periodically cannot crouch. I doesn’t matter though because nothing can see you. To fix the not being able to crouch bug just jump, or if you haven’t already walk around 15 feet and you will actually trigger the long jump feat and get a glitched skill point.
The feats are chopped off on the screen so when you earn one you don’t know which feat it is.
Hand wraps in particular are glitched in the inventory. You try and select them and the cursor just disappears. You are still officially high lighting the hand wraps though and you can probably figure out how to drop the items.
Inventory cursor makes very little sense in how it moves around and man is it a chore. You don’t even have anything complex to do in the menu.
Only one trap does meaningful damage, arrows do none as do arrow traps, the other traps take off about 1% of your health per second. Why would a stealth character put 3 skill points into lowering trap damage? I went about 5 hours only earning 1 skill point, so do that for 15 hours and I can now not take damage from traps that already don’t deal damage.
The 2 skulls in the hub say 2 things over and over again, I assume you didn’t just record 2 lines for them?
Hunger disappeared for about 10 hours and then came back for about 15 minutes and then disappeared for the rest of the game.
Sometimes you would be poisoned or caused afflictions from using spells, you die and return the affliction icons are still there however you don’t have the affliction. I cannot remember how long they glitch for, I almost never saw my health as nothing attacks you.
Near the caravan of the last level there is a giant invisible wall. Kind of underneath a little building tomb thing. Enemies seemed to see me for a change here and lots of lizards attacked me at the caravan while a quest was being given and the punk rock lizard was talking and the game crashed.
Across the game I had at least 20 crashes which is the most I have ever experienced on ps4, I could only predict the crashes coming when I burnt more than a single door down.
All the big wood set pieces cannot be burnt without the game either going about 3 fps or crashing.
When the game crashes it is a giant mystery as to where you are saved, you may get lucky or losing multiple main story missions worth of progress.
You character looks like they have parkinsons disease whenever they walk up stairs and at random yet troubling frequent times, was I hungry but the game forgot to tell me? Who knows?
Side quests seems to break the game, my hunger issues seemed to be affected by that too.
Things repopulate in the strangest ways yet other changes remain. Does burning down a bridge that crashes the ps4 create a situation where I no longer have access to that bridge in the side quests that break the game? Or will I burn it down, the bridge magically comes back to life but all the coin purses have new hiding spots? Who knows without potentially breaking their game to find out?
Fane is completely bugged, you rescue him but his is still trapped in his cage.

At one point I was apparently told a very important word by a mushroom man. The thing is that one exact word was blocked off by a confirm option. At the end of the game I discovered that the word this mushroom man told me was basically some key plot point. Otherside couldn’t even make it so one single word that apparently is really important to the story can be seen by the player. Once again I doubt I am explaining myself well but I’m sure the devs know what I mean.

So what’s good?

The fact I think your QA testers were trying to make you look bad.
The fact I get to actually be on the bleeding edge of one of worst games of all time. This is Big Rigs 2 and I have the trophies to prove I beat it and am in the top 1%. I always knew I was an outlier.

Maybe the fact it kinda looks like ultima 8.
A few labyrinth sections let me imagine what another dev could do with whoever made the labyrinth bits. But really they feel more like bards tale/might and magic hallways and not ultima underworld or arx fatalis or even dark messiah dungeons. Also these labyrinth bits take all of 10 minutes to explore, then it’s back to scratching your head wondering if your spell combo is wrong or the game just glitched and you were actually doing everything right all along.

Who knows?


#2

Astounding in 5 dimensions! You finished the game? The game is so easy for you that you needed bugs and glitches and crashes to make it kind of a challenge. This is exactly the kind of review that desperately needs recorded proof that speaks for itself and is shared, dammit!!

If true, the people who robbed their employers pretending to do the jobs and tasks they took on, and who need to be fired, and who need reputations smeared, need that footage shown to publicly shame them. Players who haven’t experienced so much of this in their playthroughs need a good blooper reel. Vloggers need memes of this caliber. People who want the game to be whole, and functional, and fun for the right reasons, need to see exactly what the devs say they aren’t seeing on their end, to investigate better. Forum moderators need to see you for the hero you are–or are not!

This also demands a unique Achievement awarded.


#3

well whatever that means jtr7 you’re more than welcome to say it


#4

Ahah that’s an epic review.

I don’t have the PS4 version, but it seems familiar. That’s more or less the state the PC version was at release last year.

Come on Otherside, how can you keep messing up like that ?


#5

I feel your pain Nyast. I thought the 1st pc players must be blowing things out of proportion.