PS4 Issues in detail


#1

I have had the game on PS4 since day one and have made it to the end of the first major level (the one with the Necrotic Graveyard). The game has a lot of potential but also a lot of issues which I’ve outlined below:

  1. Ineffective arrows. I know that they are pretty useless against skeletons but they also seem unable to strike anything else effectively. It took 10 tries to knock down a candelabra and around 20 well aimed shots to defeat an eidolon. Something is definitely amiss with targets’ hit boxes and/or the damage output of arrows.
  2. Disappearing traps: often traps, such as the rotating blades and pendulums, simply vanish. They may or may not reappear randomly.
  3. The inventory system needs work. It took me ages to work out how to drop an item (press triangle over the item) because the game didn’t tell me how to do this. The inventory itself is generally messy.
  4. The physics system is great when it works and terrible when it doesn’t. Stacking objects, such as crates, is often a nightmare. A Deus Ex system would have been far preferable.
  5. Nearly every coin purse I have found is Depleted and most loot is broken. Loot hunting is therefore a waste of time. I don’t know if items can be repaired but I don’t want to be lugging around stacks of useless, broken items.
  6. The NPC Fayne reappears in his cage in the dungeons even after you have rescued him.
  7. The lack of skill point rewards is concerning. Points should be awarded for the completion of quests, especially main story quests. Side quests seem irrelevant as they only seem to award small amounts of money and reputation and require you to trawl through areas of the dungeon you have already spent a lot of time in.
    As I said, there are things that I like, such as the level design and general atmosphere. I hope that the bugs can be dealt with and gameplay issues resolved. In all honesty the game shouldn’t have been released on the PS4 as it is and I’m surprised it passed certification. However, I am prepared to give it another shot.

#2

It gets worse, so much worse. Have you seen a bellum yet? They look like those pinky enemies from doom. I have seen about half a dozen and none can see me, not one will attack me. Infact almost every enemy cannot see me and I realise I wasn’t stealthing anything successfully. The game is so broken they hope we don’t notice how broken detection is and conclude we are successfully stealthing. I have had every problem you mentioned along with:

Items named things like sword.doc.underworld.dat

Enemies that cannot walk over ground 2 inches higher and cannot actually fight you

Enemies that don’t react (I’d say at least 50% of all enemies) to anything including being attacked

Volcanic fissures that block everything, no enemy can path find over them.

At least 50% of feats don’t register so i cannot level anything up

The feats notification is half chopped off so you don’t know what feat you achieved

That fane guy walks around randomly and will just attack me, but them still be in his cell and standing around at the caravan, there are at least 4 of him because you can summon him via magic. Not sure why though, he will stand there and do nothing if summoned and occasionally try and kill me.

Constant crashes

I turn in quests but nothing is recorded regarding quest specifics. What I mean is I turn in main story quests and the quest results say I killed 0 enemies, had 0 detections etc when I killed dozens of enemies. Perhaps the enemies need to not bug out for the game to record them as killed but I suspect the open world update messed up when the game thinks you take on a mission so if you need to travel to and from the hub it clears your mission stats.

The side quests create bugs in the main quest. I noticed doing side quests would result in the fast travel sending me to floors that the completed side quests were in and I had to check everywhere to set off the main story and it was only when I back tracked through the grand staircase that a voice over I had previously heard happened again that the main quest was accessible

Plus there are so many more problems but i struggle to even explain them. This is woefull, useless gaming, I’m playing to mock it now. I believe the devs tried to polish the first few hours and hook people in, it gets soooooo bad, big rigs bad if you get the reference, after a couple of hours.

I felt like some pathetic troll when I posted here, was ashamed to still buy the game day 1 full price and now I feel ripped off. This game is even worse than most people say.


#3

Just found another oddly named item, the "unlocalised pr_spiked_mace_door knocker(clone) unityengine.gameobject

This was on a quest where almost everything attacked me! Woohoo, it was fun for about 30 seconds but the enemies usually run away and all over the map, and it isn’t in response to me dealing damage or anything like that. I think the ripper was supposed to attack them? Well i lured about 6 enemies to a ripper and crouched and everything couldn’t see me and all the bad guys ran around foe ages, the ripper doesn’t notice them and then as soon as i stand i earn the long jump feat meaning i just earned my 1st skill point in about 4 hours. I’m about 15 hours in, and have been able to upgrade 5 skills out of about 50, i can’t cast many spells. Oh and earning 1 skill point for a feat still doesn’t give me enough to upgrade! So i need to wait for the game to glitch randomly to earn 1 skill point when good skills cost 5 skill points.

oh yeah and i used a trip wire which stuck to the wall and a point floating in mid air an inch away from the wall resulting in a floating trip wire that covered an inch.

All that in 10 minutes.


#4

Currently in tyball’s folly and the environments look nice but unfortunately the environment has disappeared. I’m floating on nothing, walking around bumping into absolutely nothing. The previous main story mission was a bust though. There was nothing to fight, there was about 200 coin purses, some rooms would have about 20 just lying around. Then I found spectors, none of which can see me, guarding a key so I grab the key and walk a few paces. The mission ends. I am immediately thrown out of the mission to the sound of an arrow thwack, arrows do no damage btw, and the empty room i was in is fully repopulated with enemies. Lucky for me arrows do no damage. But then I realised I was actually unlucky as I was planning on killing myself to fast travel so if arrows worked I could die to finish the game quicker. Lol


#5

I have decided to stop playing the game now until, hopefully, another update drops. I’d like to contact PlayStation about getting a refund but going from past experience the only way that they would offer a refund for a broken game is if it blew up your console and set fire to your house!


#6

We’ve been ringing the alarm bells for a year or more. The question I have for you is, why did you buy the game ? Didn’t you realize it was in a poor state ? Did you expect the PS4 version to be better ?

Did you buy the game on impulse, without researching what other players / media had to say about it?

Because the information is all over the place. Between the poor Steam ratings / reviews, the reviews on various media that all scored the game very poorly, the bottom #5 metacritic score in video game category, etc… it’s all out there.

Also, surprisingly, the PC version is now in a much better state; most of the bugs you mention have been fixed and the game’s pretty stable. I’m not sure why the PS4 is so different.


#7

I bought the game after having researched it and reading that the PS4 version was the latest one and that many of the bugs had been dealt with. As I said earlier the major issues for me are The ineffectiveness of the arrows, the lack of skill point rewards and the disappearing assets (e.g. traps).


#8

Yeah it’s surprising and worrying that the reports of the PS4 version are so poor, the PC version is much improved in terms of performance, bugs and polish.

This all sounds more like the PC game from 6 months ago!


#9

Bingo. That’s very surprising, because usually when a game gets ported you expect technical issues, like glitches, crashes, or poor optimizations; But here, it seems like most issues are still gameplay related, which have been fixed on PC. Why would a port affect gameplay code and cause arrows or traps to disappear ? That makes no sense to me.


#10

The disappearing traps is indeed a bizarre glitch; the last time I played the game the swinging pendulum blades in the prison level had gone. You could still hear them but couldn’t see them. Also all the depleted coin bags and broken loot must also be a glitch; I would say that well over 90% of coin bags I have found have been empty. I don’t see the sense in exploring a level for a hidden chest only to find that it is either empty or full of worthless tat.


#11

Items named things like sword.doc.underworld.dat and unlocalised pr_spiked_mace_door knocker(clone) unityengine.gameobject

Are you able to specify what language you’re playing in on PS4? Is this in English?

I’m logging as many PS4 bugs as I can, and some of these appear to be addressed for the PS4 hotfix we’re working on, such as arrow damage. AI should have had the improving pathing (that took up nearly half of the PS4 development time), so I’m surprised to hear it’s still so unresponsive. The final build we approved for PS4 had pretty reactive enemies. (Or so it seemed when we launched).

For your report about Tyball’s Folly, are you saying you loaded into a level but couldn’t see any of the environment assets? That has definitely not been caught before and I would love to have as much information about this as possible, if you can share it.


#12

Hi. I’m playing in English.


#13

Special case code, and poor abstractions. I tried to tell them that portable code didn’t mean putting it on a thumb drive.


#14

Are you sure the coin bags are actually empty ? In the early levels they’re called “depleted”, but they in fact contain a few coins each. You can verify that by checking the number of coins you have in your inventory, and see if it increases.

You’ll get more money and better non-breaking loot as you get deeper in the levels. There’s some kind of level scaling system I think, I’m about to reach the end of the game ( ! ) and I frequently have coin bags that contain hundreds of coins.


#15

Question: You say you are almost finished with tis game? Would you be interested, at all, in playing it again? If no, why? If yes, why??


#16

I just finished the game.

And to answer your question, no, I have no mental strength left to go for another run of the game.

I played it during the alpha, during the beta. Played half of it during the release, after which I gave up due to the poor state.

Now that after update 4 most of the technical issues (on PC) have been solved, and some of the design issues improved ( kuddos to the devs: it feels like a proper connected dungeon now ! amazing how little changes like a staircase, connecting levels together, getting ride of the magic portals design, and fast level loading, can do ! ) I decided to give it a final try.

But 90% of the interest of the game comes from exploring the levels. Once you’re done with the game, there’s little left to re-play. Maybe some of the side missions, maybe some of the areas that I didn’t back-track to and probably contained other generic chests with loot inferior to what I have.

Overall, the game’s vastly improved over its original release 8 months ago. It’s playable, but it’s still a far cry from a proper Ultima Underworld sequel. If you keep your expectations low you might have a bit of fun with it, especially if you like exploration. Managing expectations is the key.


#17

i’m playing in english. I don’t think you are focusing on the correct things. Who cares about the names of rng drops when no enemies will attack me, when missions end in empty rooms to immediately be filled with enemies attacking me etc? You say they looked to be working on your end but offer no time frame as to when you will fix it, I assume you won’t because it’s 7 months after launch and I am certain you have been trying unsuccessfully all that time. That’s why you get so eager to solve a problem like changing an item description.

as for tyballs folly when i do a main quest to kill 7 skeletons with black smoke I can go 3 ways. There is a portcullis, a way right and a way left. If you go left a lizard man (who always sees me and actually fights me) will attack me, i walk around a corner, see some crystals and then everything disappears. The game crashed after completing this mission and my silver sapling save didn’t register for some reason so I had to do the quest again. So i checked to see if the problem was there a second time and it was. It was not a random one off bug it seems.

I’m very much in front of the other ps4 players, i notice i have achievements only a few percent have and these are just achievements for collecting the keys.

I have 12000 silver as well and lots of that came from that mission with a few hundred coin purses. I have so many items worth 4000 plus and nothing to buy so if i sell items I probably have about 25000, I have done maybe 3 sidequests before I realised they were making the main story bug out so i am bee lining for the end and still have so much money and items.

But even if you get the pathfinding, make the enemies see the player, make it so tyballs folly doesn’t disappear, make the Bellum do something other than run around like a shaved armless chimp, you still need to explain what is actually happening. I only know about the factions because i followed this game, i am flat out confused about marcul, why is there so much space? what is a mana core? I have lots of them. You put them in the other machine that gets no explanation. The mana core looks like that aether core thingo and i put the aether thingo in the cauldron machine and now less pots have lava in them? OK now what?

What am I even doing in this underworld? finding keys to open a door but first i need to keep people happy who don’t exist so 1 item every now and then can be purchased? but i also need to find cores that go in machines that do something? All the while I find writings from 1 perosn to another all game? You’re really making the underworld feel like 2 people live in it. 2 people fleeing a bank robbery it seems on account of the THOUSANDS of coin purses. Go back to ore, that makes some sense

You need to:
make it so you can level up, having a ground breaking feats system that is broken is just an insult.

make enemies attack you, it’s that simple

Make loading screens plainly explain what is going on. Not randomly so near the end you get a useful tip, make the very first dozen loading screens explain what is happening with story, mana cores, who the lizards you free are etc Just plainly. Say “There are lizard allies that will aid you in battle if you free them from their cages. They appear on the map as a lizard icon” Explain things like that to the player at the start. Surely changing text is about the simplest coding you could do. I understand different languages make it less simple but come on, you need to make it clear what the heck is going on. I know I could chuck a few more mana cores into the other machine but it doesn’t seem to do anything and I’m trying to finish this game fast now so i don’t want to risk more crashes just trying to go there to feel like a moron as I put more unexplained cores into some unexplained machine.

make sure levels don’t contain hundreds of coin pouches/purses/money bags. At least mineral ore made some sense. But who left these purses? About half a dozen people live in the underworld. From a practical view point i have no interest in items, money, all i want are feats to register. Also there are way too many chests, no excitement, just another room with loot i don’t want. But I suspect removing chests is harder than changing spawn rates of coin purses.

I know, giant wall of text, you probably only were able to make out a few critiques like “silly other side you forgot to give that one mace a proper name” or “Oh so you say you love how the environments looked before they disappeared?, thanks for the compliment”


#18

You aren’t having a conversation with someone working on the code. You aren’t having a conversation with someone working on a console team or at those companies. You aren’t talking to the deadline makers.

Specific details matter very much. It doesn’t have to make sense to you, but to the developers. It saves time on their end if they don’t have to guess at details. If you really wanna help them help you, save them time by being as specific and accurate as possible. How you feel but can’t be acted on by them where fixes to the games are concerned.


#19

I’m not having a conversation with anyone. I am reviewing the game as I play it on the ps4 so that others thinking about buying it reconsider. The devs and deadline people don’t post here but you would have to be a moron to think they don’t read what’s posted here. Especially a week after release. Anyone white knighting for this severely under estimates the intelligence of the consumer, thus the low player count.


#20

I didn’t realise that depleted bags might contain a few coins. Wouldn’t it be better to rename the bags so that you know what they contain?